Archive for 2006年1月15日


微软的成功之道

     作为全球最成功的企业之一,微软公司在过去的二十多年里为全世界数以亿计的用户提供了无数杰出的软件产品,并以自己的实践经历揭示了软件产业内蕴藏的旺盛生命力和巨大商业价值。微软公司目前的市值是3100亿美元。在2005财政年度里,微软公司的销售收入将达约400亿美元,实现利润165亿美元。去年派发330亿美元的股息后,微软公司仍拥有350亿美元的现金储备。

     我认为,微软不断走向成功的原因主要有四点:(1)技术:用创新的精神把握技术发展的脉搏,以合理的研发体系保证企业的效率,以执著的态度专注于软件业的发展;(2) 领导艺术:最高决策者拥有卓越的才识、明确的分工和完美的合作;(3)人才:多渠道发现和聘用人才,有效的人才筛选机制,对人才的持续培养以及知人善用;(4)企业文化:不惧挑战、自我批评、灵活平等以及对客户负责的态度已经在微软形成了一种传统,并得到了制度化的保证。下面,我将从这四个方面出发,分别介绍微软公司的运营和管理经验,希望对中国的高新技术企业有所帮助。
 

     技术:微软的希望之光    

(1)与时俱进、不断创新
     三四百年前,知识是在很长的时间里慢慢积累起来的。但自工业革命以来,科技的进步已经不再是靠历史的积累,而更重要的是靠不断的创新。信息革命后,科技的成长呈现出指数增长的趋势。在信息技术方面,过去十年中人类获得的知识和经验毫无疑问已远远超过了过去一百年的积累。

     微软公司深深地理解,在这样的大环境中把握技术方向的重要性。当微软公司在早期的Basic产品中获得成功后,开始投入DOS的研发。DOS成功后,微软立即将资金和人力投入到新技术的研发中,并成功推出了Office系列软件产品。随后,微软又利用Office等软件获得的积累,开始了Windows NT、Windows 2000、Windows XP等新一代操作系统的研发。当Internet浪潮到来时,微软不失时机地跻身网络研发领域,并不断推出新的产品。今天,微软又把大量的资源投入到“无缝计算”的核心方向,在发展MSN、移动软件、数字电视、XBOX、高可信度计算、自然用户界面等方面不断创新。

     在技术浪潮的推动下,微软公司总是把技术研发摆在关键地位,并将技术看作公司惟一可长期延续的财富和优势。例如,微软在2005财政年在研发领域投入大约85亿美元,超过其营业额的五分之一,这个比例在“世界财富500强”的企业中居首位。

(2)运筹帷幄的“首席架构师”
     要重视技术,企业就必须要有一个最高的技术决策者。现在,微软公司的这个决策者就是比尔•盖茨,微软的“首席架构师”。设立这个特殊职位是因为,无论在微软还是在其他公司,首席执行官根本没有时间管技术,而很多所谓的“首席技术官”却都是没有实权的科学家,决定不了技术发展方向。但是,在一个技术主导的行业里,一个企业没有技术方向的最高决策者是不行的。

     作为首席架构师,比尔•盖茨的工作是制定公司的长期技术路线图,并确认公司每一个行政部门的科研计划是互补而不是重叠的。因此,他要求公司的每一个产品和技术部门都向他做技术汇报,这些汇报大多是“头脑风暴”式的讨论会议。做这样的汇报,除了可以得到比尔•盖茨的回馈之外,每个项目团队还可以在准备过程中受益匪浅。因为,项目团队为了准备回答比尔可能问到的各种问题,必须在报告前彻底调研市场、技术、竞争对手等信息,也因此避免了闭门造车的风险。

     另外,比尔•盖茨每年都会抽两段时间,用“闭关”的方式独自思考问题,这被称为比尔•盖茨的“思考周”。在“思考周”之前,盖茨会要求各部门精英在他们个人的专长领域给他提供大量阅读材料和技术建议。在“思考周”里,盖茨通常的工作方式是埋头阅读经过筛选的材料和技术建议,记下自己的想法,静静思考,最终做出一些对公司技术战略有较大影响的重要决定。

(3)不断完善的研发机制
     为了更快、更好地将未来的技术变成现实中的软件产品,微软公司不但在技术研发上投入了大量资源,而且建立了完善的技术管理制度。比尔•盖茨成立了“卓越工程”部门,负责确认公司的研发机制是有活力的,开发过程是最有效率的,开发出的软件是安全可靠的,并避免不同部门之间的重叠开发。这个部门具有管理公司工程流程的实权,这样才能带领整个公司走在软件业的前端。

     微软公司对技术研发的投入是坚定不移的。微软很早就创立了它著名的研究机构(例如微软亚洲研究院),并充分认识到,科学研究和产品开发工作间存在着巨大的差异。研究工作鼓励冒险不惧怕失败,鼓励研究者拥有长远的目标和规划,做长期投资;而产品开发工作则更多地考虑眼前的利益,其目的只有一个,就是满足客户的需求。研究机构发展科技,生产部门制造产品,研究人员通常都是“思想家”,而产品开发人员更多的是“实践家”。这两类工作和两种技术人员之间的差别非常明显,如果我们希望更好地促进研究成果向实际产品的转移,就必须在保持它们各自特色的基础上,为它们的协作创造良好的环境和条件。

     为了促进研究成果的转移,微软鼓励研究人员充当新技术的推销者,向产品部门推销科技成果,同时也鼓励产品部门把用户需求和产业发展态势及时反馈给研究部门。比尔•盖茨最近在一次演讲中说,微软公司要做两类事情,一类是满足用户现在的需求,另外一类是满足用户未来的需求。这表明,微软公司已经将科研和开发视作了公司发展的两条主线。事实上,微软既为两类不同的机构制定了共同的目标,建立了沟通渠道,也严格划清了二者的界限,为不同类型的机构制定了不同的考评制度。同时,微软也允许并鼓励人才在两类机构间转移和流动。现在,微软研究院每年都会向产品部门输出大量科研成果,这些成果大多都被应用到了微软公司各类成功的软件产品上。

(4)专注于最擅长的软件业务
     微软公司是一家专注于软件技术和软件产品研发的公司。虽然微软公司也投资于MSN等内容服务和XBOX等硬件产品,这些产品的最终目的还是推进软件和软件平台。微软公司的主体始终是软件,微软绝大部分销售收入也是由软件创造的。微软公司对自己的定位是,在信息产业的整个生态系统中,专注于扮演纯粹的软件提供商的角色,其他的角色由戴尔、HP、Accenture等公司扮演。只有这样,微软才能把自己的专长做到最好,以保持在软件领域的领先地位。

     “专注”对公司很重要,因为一个公司的成功也来源于管理者或领导者的注意力。许多公司的领导者可能会因为急于发展,带领公司向多个不同的方向发展。比如,某些大型IT企业在积累了一定财富后就会把资金投入到硬件、服务,或甚至房地产、传媒等其他行业中。这么做就分散了公司的注意力,而公司的领导者也不见得有能力或激情来管理这些新开创的企业。但微软公司的领导层总是把注意力放在七个基础的商业部门的软件业务。这七个部门都以开发软件为己任,以软件平台为核心,以比尔•盖茨为总架构师。这样,七个部门的领导者才能有共同的语言、共同的管理方式、共同的对软件的专注与热情,不必分心于自己不擅长或没兴趣的事情,才能如鱼得水,在微软发挥个人的潜力。
 

     领导:微软的成功之源    

     微软公司的成功,在很大程度上得益于微软公司拥有两位杰出的领导人:比尔•盖茨和史蒂夫•鲍尔默。在2000年之前,微软惟一的领导者是比尔。2000年1月,为了更好地把握技术方向,比尔把首席执行官的工作交给了史蒂夫,自己做“董事长兼首席架构师”。后来,史蒂夫又把公司分为七大商业部门,每一个部门负责一系列的产品和用户(例如:大企业部门负责Windows、SQL Server等服务器软件和工具;家庭娱乐部门负责XBOX、电视软件平台和游戏软件等)。从2000年以来,比尔和史蒂夫成为最佳搭档,两人带领七个部门在经济风暴中稳定成长,实为公司成功最大的原因之一。

(1)首席架构师比尔•盖茨
     比尔•盖茨是微软公司的技术带头人。他善于通过自己的远见卓识,在技术上把握公司的发展方向,不断为公司的新产品研发制定战略目标。通过前面介绍的“思考周”、“头脑风暴会议”等形式,比尔•盖茨在全公司范围内集思广益,收集最新的信息,以保证技术决策的正确性和前瞻性。

     比尔的另一项工作是协调公司软件的投资,并避免七大商业部门的重叠投资。他会深入了解每一项重要技术,把开发任务交给某一个部门,并要求该部门把另外六个部门当做重要客户,同时也要求其他六个部门不要重叠投资。例如,虽然七个部门都需要语音技术,但是比尔却该技术的开发任务交给了我的部门。这样的安排让我不用担心公司内部的竞争,而且,我所在团队里的员工也会因为自己的产品能影响到其他各部门的产品而更有成就感。

     比尔•盖茨还要负责决定全公司七大商业部门在各个研发方向上的技术资源分配情况。大多数公司可能会把最多的资源分配在最赚钱的部门里。但微软并不是这样做的。例如,微软公司负责Office产品研发的部门人数并不很多,相反,服务器和工具部门却拥有最多的技术员工。这主要是因为,微软在后台服务领域面临着更加激烈的市场竞争,需要投入更多的资源,以尽快开发出领先于IBM、Sun 等竞争对手的重量级产品。微软公司在移动产品部门投入大量资源,也是因为比尔•盖茨看好移动通信领域的巨大市场前景。因为微软公司内的七大商业部门并不是完全独立的,比尔•盖茨就可以根据自己对技术方向的判断,把有限的资源调配给最具有发展潜力或竞争最激烈的技术领域。

(2)首席执行官史蒂夫•鲍尔默
     史蒂夫•鲍尔默是微软公司的头号啦啦队长。他是一个非常有激情的人,说话声音很大,非常有力量,而且很感性,很有穿透力。他是一个全能领导者,既有商业头脑,又有战略眼光,能鼓舞士气,还富有激情,精通技术。微软公司的人常说,史蒂夫给下级做考评的时候,就像在“奥数班”一样,要求甚高而不允许犯错。当下级把总结报告提交上去后,史蒂夫只看一眼,就可以从中挑出几个乃至十几个不恰当的地方。通过这样的考评,下级员工可以收获到非常多的经验和知识,可以在以后的工作中做得更好。

     当微软把全公司整合成七大商业部门之后,史蒂夫•鲍尔默适时地由前台退到了后台。他不再做具体的管理者,而是转变成了七大部门主管的背后支持者。他不再做每件大事的最后决定人,而是支持着七个部门主管的成长。他不再做一个最有煽动力的啦啦队长,而成为一个幕后的教练。史蒂夫支持七大部门的主管放手施展自己的管理才华,而他自己则把更多的时间花在了公司的价值观和人才建设上。

(3)最佳搭档
     比尔•盖茨和史蒂夫•鲍尔默是微软公司最重要的两个人。在我所经历过的高科技公司里,员工总是喜爱抱怨公司的最上层领导,但是在微软,几乎所有员工都对比尔和史蒂夫无比钦佩。和他们共事多年,我认为他们两个人都是非常有才华,能够集谦虚、勇敢和毅力于一身,勇于从失败中吸取教训。他们二人最特别的三个优点是:

1. 勇于改变、适应力强:比尔和史蒂夫都是适应能力很强的人,能够根据情况的变化及时调整自己的工作角色和工作方式。他们两个人都在不断地学习,不断改进自己的工作。例如,比尔在演讲失败后,勇于拜师学习演讲技巧;2000年时,为了企业更好地发展,比尔将首席执行官一职交给史蒂夫;设立七大商业部门后,史蒂夫从啦啦队长转型成为幕后的教练……这些都是微软员工津津乐道的例子。
2. 对公司充满热爱和激情:比尔和史蒂夫早已不是为了赚钱而工作,而是为了公司,为了用户,为了享受激情和快乐而工作。他们很多年没有拿股票和认股权,把上亿的财富让给了员工。正因为他们对公司的热情感染了所有的员工,微软才能汇集全公司所有人的智慧,共同为公司创造最大的价值。
3. 彼此信任、相互支持:对微软来说最难得的是,比尔和史蒂夫两人百分之百地彼此信任,共同推动微软公司向前发展,共同完成了2000年到今天完美的职位交接,共同负责创造公司的未来。他们之间从未发生权力斗争、政治纠纷一类的问题。这在今天这个现实、自私的社会中是最难能可贵的事,也是微软公司成功路上的佳话。

     虽然比尔和史蒂夫都还年轻,精力旺盛,离退休的时间还早,但他们已经开始了接班人的培养工作。这样,即使他们退休之后,微软公司也能延续他们的管理风格和管理理念,并不断取得成功。
 

     人才:微软的立业之本    

     微软公司把重视人才的管理理念视为公司的核心财富。在信息时代里,人才的价值尤为重要。在工业时代里,一个优秀技工和一个普通技工的效率差异可能是30%,但在信息时代里,一个高级程序员和一个普通程序员的效率差异可能高达10倍以上。例如,微软公司有一位编程高手,一次,他对一位经理说,你们的产品里还缺少一种重要的功能。那位经理说,我也想做这个功能,但至少要50个人半年时间,现在已经来不及了。编程高手什么也没说就走了,第二个星期开会时,他对那位经理说,你要的功能我已经帮你做完了。因为这样一位编程高手可能知道很多其他程序员所不知道的解决问题的捷径,他在一个星期里就能做完50个人半年的工作。可见,这样的人才对公司来讲是有特殊意义的,公司必须善于追踪、挖掘、面试、聘请、评估、培养、重视和留住这样的人才,而且要把人才相关的工作视为公司最重要的任务之一。

(1)求贤若渴:追踪和挖掘人才
     重视人才的一个最直接的体现就是管理者要善于雇佣高水平的人才,而微软公司的各级管理者都非常善于发现和雇佣人才,无论对方是大师级的人才,还是应届大学毕业生或已离开公司的人。

     例如,微软公司最重要的领导和大师 Jim Allchin目前在微软公司负责平台产品研发。当年,比尔•盖茨想请他加入微软的时候,通过朋友多次联系他,Jim Allchin都置之不理。后来,经过比尔再三邀请,Jim终于答应来面试。结果,Jim一见到比尔就直接了当地说,微软的软件是世界最烂的,实在不懂比尔请他来做什么。比尔•盖茨不但不介意,反而对他说,正是因为微软的软件存在各种缺陷,微软才需要你这样的人才。比尔•盖茨的虚怀若谷感动了Jim Allchin,终于把他请到了微软公司。再例如,IBM著名的深蓝计算机的设计者许峰雄博士此前也加盟了微软公司。许峰雄博士是我的好朋友,我追踪他至少五年了。逢年过节时,我总会给许峰雄博士打电话,聊一聊他的近况,探听一下他的想法。年复一年,我终于打动了许峰雄博士,有幸邀请他到微软来工作。虽然他最后加入的不是我的团队,但是我一样引以为豪。在微软,许多人都像我一样主动从事发现人才、跟踪人才和吸引人才的工作。

     除了努力挖掘、追踪许峰雄、Jim Allchin这样的大师之外,微软也非常善于直接从学校雇佣刚毕业的大学生。每年我都会去两三个大学亲自面试最优秀的应届毕业生。我们曾经做过一个统计,直接从学校雇佣的人才,在总体表现上要优于从社会雇佣的更有经验的人才。我们也发现,今天微软大部分的副总裁都是在大学毕业后直接进入微软公司的。直接从学校雇佣和培养人才有很多好处:人才可塑性强,对公司忠诚度更高,最愿意全力以赴地办事,不怕风险,愿意积累多部门的经验。

     此外,微软公司一直追踪着离开公司的优秀员工。我们并不认为员工跳槽是一件坏事。对于离开公司的优秀员工,微软会认真分析该员工离开公司的原因,以便进一步改进工作。同时,微软也会对他们离职后的工作情况进行追踪,准备在合适的时间再把他们请回微软。这种鼓励人才流动的机制可以更好地激发人才的积极性,可以真正得到员工的信任和支持。

(2)任人唯贤:面试和聘请人才    
     微软的面试机制是众所周知的。微软对于面试采取了严谨的态度,采用精心设计的面试流程。每一个申请者的面试都有多位微软员工参加,每一位参加面试的员工都事先分配好面试时的任务。除了确认专业知识和经验之外,我们也会出很多题目来测试申请者的独立思考能力及面对难关时的表现。我们不只要雇佣那些技术上的专家,还应当雇佣聪明、学习能力强、有团队精神的人。所以,面试时对这些方面也要深入地询问。每一次面试后,面试者都会把他的意见和下面应该考核的问题交给后续的面试者。最后,只有得到绝大多数参与面试者的同意,并在明察暗访所得的结果令我们满意时,微软才会聘用该申请者。

     任人唯贤是微软公司一贯遵循的用人理念。我们深信两句话:(1)一流的人雇佣一流的人,二流的人雇佣三流的人。因此,当一个队伍雇用第一个二流的人的时候,就是它走下坡路的时候。(2)雇佣人才应以提高组织当前的整体素质为标准。我们必须要求每一个新雇员的素质都超过整个团队的平均水平,以此来提升团队的平均素质,而不是降低团队的素质。所以,微软公司的管理者总是希望雇佣到比自己强的人才。如果你雇佣的人才最终能成为你的上司,你不但不应当感到羞愧,而应该感到无比的自豪。

(3)人尽其才:评估和培养人才
     雇用员工之后,公司会定期对人才状况进行评估和分析。每年,史蒂夫•鲍尔默都会要求七大商业部门的管理者把本部门最杰出的50到150位人才的详细情况报告上来,史蒂夫把总共约600人的资料装订成一本独特的《人才报告》,然后花上整整两星期的时间来评估这些人才的发展前景,每天还会邀请这些人中的20位共进晚餐,以进一步了解这些人才。这样的工作可以为高级人才在公司内的发展设计最好的路径,也可以在公司有空缺职位的时候迅速找到合适的人选。史蒂夫期望自己认识这600人中的每一位。他把这本书放在他床前,每晚睡前都会认真地读几页这本书。

     微软深信“人尽其才”,所以设计了“双轨道”机制,既允许优秀员工在管理轨道上发展,也允许他们根据自己的意愿,在技术轨道上发展。在每个轨道上,微软为员工提供的机会是平等的,员工并不一定非要做管理工作才能促进个人事业的发展。在微软,一个最高级别的工程师可能比副总裁还要资深。这样的“双轨道”政策从制度上保证了人才发展道路的多样性,有利于吸引人才和留住人才。

     微软公司鼓励公司内部人才的流动和发展。各级管理者都遵循人尽其材的方式给每一个优秀的人才发展的空间。各级管理者也深深理解“最优秀的人不属于我,而属于公司”,他们不会把人才据为己有,而是给最优秀的人才更好的发展机会,无论这个机会是不是由自己所管理的机构提供的。在这样的制度下,优秀的人才大多能找到适合自己的发展道路。

     除了培养优秀的人才之外,公司也必须发现并督促那些表现较差的员工,给他们机会改进,否则就只有要求他们离开。为了达到这个目的,微软公司建立了完善的分级评估体系,并定期对员工的工作表现进行考核。在每一年度的考核中,每一个副总裁必须把他部门所有的员工分成四个等级:(1)超过期望,(2)达到期望,(3)达到大部分期望,(4)没有达到期望。每一个等级必须有合理的比例,总会有相当一部分员工被评为第三或第四等。其中,拿到第四等(大约是5%左右)的员工等于是拿到了“不改进就得走”的信息。

     史蒂夫•鲍尔默深深地理解,这样的制度如果不是以身作则,就无法得到员工的支持和信服。所以,即便在副总裁或总经理这一级,微软公司也施行严格的淘汰制。有一次,史蒂夫召集了公司最资深的100个人开会,并告诉我们说,“我要求你们找出最差的5%的员工,不论他们资历如何,都要给他们一个不改进就得走的警告。‘不论资历’的意思是,今天有你们这100位高级经理在这里开会,而明年开会时,就应该只有95个人了。”结果,下一次开会时,果真有不只5位高级经理已经离职。

(4)才尽其用:重视和留住人才
     很多人认为,留住人才的关键是待遇。的确,每个人都应该得到适当的待遇,但对一个软件从业人员来说,他更看重的是工作环境如何。与提高员工待遇相比,微软更注重做到提供一个能够吸引人、留住人的环境,这包括:
          有众多的产品,能让员工发挥才华和潜力,做出最大的贡献;
      充分的资源支持,让每个人都没有后顾之忧;
      最佳的队伍和开放、平等的环境,让每个人都有彼此切磋、彼此学习的机会;
      吸引人的科研工作,让每个人都热爱自己的工作;
      领导者理解并支持员工的研究,让每个人都能在紧随公司的大方向的同时,仍有足够的空间及自由去发展自己的才能,追求自己的梦想。
 

     文化:微软的经营之道    

     一个企业的文化和价值观是它的精神、思维方式和行为方式,是企业全体成员在生产经营活动过程中形成的一种行为规范和价值观念。

     微软公司的价值观既是公司二十多年来在实际工作实践中,从发展过程里长期积累的精神财富,也是公司根据竞争环境的需要不断调整、不断完善的结果。微软公司今天的价值观主要包括:诚实和守信;公开交流,尊重他人,与他人共同进步;勇于面对重大挑战;对客户、合作伙伴和技术充满激情;信守对客户、投资人、合作伙伴和雇员的承诺,对结果负责;善于自我批评和自我改进、永不自满等。

     以上这些价值观不仅仅是纸面上的文字,微软公司在日常工作中也时刻注意提醒员工遵守这些基本的工作准则,并要求员工把这些价值观转换成可以付诸实践的具体目标。有了这些价值观的帮助,微软公司的员工可以进一步增强对微软企业文化的认同,可以在工作中发挥更大的潜力。

     在微软的文化和价值观中,我认为以下五点对微软的成功最有帮助:(1)充满激情、迎接挑战,(2)自由平等、以德服人,(3)自我批评、追求卓越,(4)责任至上、善始善终,(5)虚怀若谷、服务客户。

(1)充满激情、迎接挑战
     微软公司的经营宗旨是随着时代的发展而不断变化的。同样的道理,微软的企业文化也在不断地完善和发展。但是最能体现微软企业文化精髓的,还是比尔•盖茨的一句话,这句话多年后还是那么贴切:“每天清晨当你醒来时,都会为技术进步及其为人类生活带来的发展和改进而激动不已。”

     也就是这样的雄心壮志让微软一次又一次地向最困难的目标发起挑战。当DOS刚取得成功时,微软就果断地决定要取代自己的成功产品,开始发展Windows。当Windows还远远没有成型时,微软又决定花大量的资源做Windows版本的Word和Excel。那时,DOS版本的Word 和Excel远远落后于竞争对手,而微软却把更大的投资放到Windows版本上,这等于是加倍了在Windows上投入的赌注。回顾这样的大手笔、大挑战,一位经理说:“如果Windows失败了,就没有微软这个公司了。”在Windows 之后,微软在Office、Windows NT、Internet、.NET等机会来临时,一次又一次地“把公司当作赌注”,并一次又一次地在重重挑战之下给公司带来了新的生命力。

     公司不畏挑战的精神,可以从微软前景目标的演变中看出来。28年前,微软公司的前景目标是“让每张桌上都有一台个人电脑”。现在看来,这个目标并不稀奇;但在28年前,这是一件令人难以想象的事。在上述目标已经基本成为现实的今天,微软公司又有了新的前景目标,那就是“通过优秀的软件(在任何时间、任何地点、通过任何设备)帮助人们发挥潜力”。微软公司认为,人的潜力需要借助有效的工具才能淋漓尽致地发挥出来,而代表现代社会信息化进程的电脑以及优秀的软件产品就是这样可以帮助人们充分展示创造力和工作热情的工具。

     公司一次次地面临重大挑战,一次次地推出成功产品,一次次改变了人类的生活。这一切都极大鼓舞了公司员工的士气,带给他们高度的满足感,让每一个员工“为人类生活带来的发展和改进”、“为帮助人们发挥潜力”而激动不已。

(2)自由平等、以德服人
     微软公司是我见过的公司里,最没有官僚作风的。公司放权给每一个人主导自己的工作。公司没有“打卡”的制度,每个人上下班的时间基本上由自己决定。

     公司支持人人平等,资深人员基本上没有“特权”,依然要自己回电子邮件,自己倒咖啡,自己找停车位,每个人的办公室基本上都一样大。有一次,一些从中国来访微软的教授在等待听Jim Gray(发明数据库的著名科学家,图灵奖的获得者,加州研究院的院长)的演讲时,看见一个满头华发的老头趴在地上接电线,还以为他只是一名老工人。等他站起来时,大家却惊讶地发现,他就是演讲者Jim Gray。这些教授都很震惊,没想到连Jim这样的人都亲自动手接线装电脑。微软就是这样一个崇尚技术、人人平等的公司。

     公司主张施行“开门政策”,也就是说,任何人可以找任何人谈任何话题,当然任何人也都可以发电子邮件给任何人。一次,有一个新的员工开车上班时撞了比尔•盖茨停着的新车。她吓得问老板怎么办,老板说:“你发一封电子邮件道歉就是了。”她发出电子邮件后,在一小时之内,比尔不但回信告诉她,别担心,只要没伤到人就好,还对她加入公司表示欢迎。
   
      一个平等的公司可以降低公司内部的信息阻塞,增加所有员工的主人翁精神,还能更早地发现公司在发展中遇到的问题。平等的公司可以说是微软发展的必备平台。

(3)自我批评、追求卓越
     微软文化的一大特色就是自我批评。在科技呈指数趋势飞跃发展的今天,不愿意批评自己,不承认自己的错误,不追求卓越的公司将面临灭亡。

     我认识一个刚加入微软的市场经理,他代表我们的产品去参加一个商品展。回来后,他兴高采烈地发了一封电子邮件给整个产品小组。他说:“我很高兴地告诉大家,我们在这个展览获得了令人振奋的成绩。十项大奖中我们囊括了九项。让我们去庆祝吧!”但是,他没想到,在一个小时内,他收到了十多封回信。大家问他:“没得到的是哪一个奖?为什么不告诉我们?为什么没得到那个奖?我们得到什么教训?明年怎么样才能得到这第十个奖?”他告诉我,在那一刻,他才理解了微软为什么会成功。

     自我批评在公司早已被系统化。每一个产品推出后,会有一段特别时间空出来给产品团队做“post-mortem”,也就是系统化的“自我批评”。所有小组成员都会被询问,什么地方可以做得更好,每一个动作和决定都会被分析,结果将在公司公布,以帮助别的小组避免同样的问题,让公司的项目能越做越好。

     比尔•盖茨鼓励员工畅所欲言,对公司的发展、存在的问题,甚至上司的缺点,毫无保留地提出批评、建议或提案。他说:“如果人人都能提出建议,就说明人人都在关心公司,公司才会有前途。”微软开发了满意度调查软件,每年至少做一次员工满意度调查,让员工以匿名的方式对公司、领导、老板等各方面作回馈。其中有选择题(例如:“我对我的副总裁有信心。以下选一 : 非常同意、同意、无意见、不同意、非常不同意),也有问答题(例如:你对公司战略有什么建议?)。每个经理都会得到多方面的回馈和客观的打分。比尔、史蒂夫、其他高层领导和人事室都会仔细地研究每个组和经理的结果,计划如何改进。

     除了自我批评,还要有能接受别人批评的胸怀,和改变自己的魄力。1995年,当比尔•盖茨宣布不涉足Internet领域产品的时候,很多员工提出了反对意见。其中,有几位员工直接发信给比尔说,你这是一个错误的决定。当比尔•盖茨发现有许多他尊敬的人持反对的意见时,又花了更多的时间与这些员工见面,最后写出了《互联网浪潮》这篇文章,承认了自己的过错,扭转了公司的发展方向。同时,他把许多优秀的员工调到Internet部门,并取消或削减了许多产品,以便把资源调入Internet部门。当时,有些员工在某一天上班时,老板会告诉他:“我们的产品被取消了,因为公司需要我们做更重要的IE浏览器。明天起,我们整个部门将加入Internet部门。”那些批评比尔•盖茨的人不但没有受处分,而且得到重用,今天都成了公司重要部门的领导。在软件这个市场变化迅速的领域,调整企业方向对微软无比重要。从这个例子里我们看到的是:平等的环境、直接的沟通、宽大的胸怀、宏大的魄力拯救了公司。

(4)责任至上、善始善终
     公司和领导者有了关注的目标之后,还要有足够的责任心,才能把事情做好。微软公司要求每一个部门、每一个员工都要有自己明确的目标,同时,这些目标必须是“SMART”的,也就是:
     • S – Specific (特定的、范围明确的,而不是宽泛的)
     • M – Measurable (可以度量的,不是模糊的)
     • A – Attainable (可实现的,不是理想化的)
     • R – Result-based (基于结果而非行为或过程)
     • T – Time-based (有时间限制,而不是遥遥无期的)

     只有每个人都拥有了明确的目标,并可以随时检查自己是否达到了预先设定的目标,公司员工才能在工作中体现出强烈的责任感和工作热情。

     微软公司要求部门和员工制定的目标必须是可分享的,即,每个人都应当通过某种渠道,如公司的内部网站等将自己的目标公布出来(当然,某些需要保密的工作目标除外)。这样,当某位员工对领导或其他员工的工作方式不理解的时候,就可以去查看对方的工作目标,以寻求最好的沟通和理解。

     除了针对目标、结果的负责,公司更需要在决策方面有负责的框架。微软的“决策制定框架”下,每一项重要决策都有一定的制定流程和人员角色划分。每一个决策流程的推动人很自然地就是决策的责任人。对该决策有支持和认可权利的人是决策的审批者。对该决策进行核查、提出支持或反对意见的人是决策的复核者。在整个决策流程中,虽然复核者可提出反对意见,但审批者仍拥有决策的最终决定权。有了这样的框架,公司的决策流程更加清晰,人员责任更加明确,决策不会被轻易拖延或推翻,决策的效率也大大提高了。

(5)虚怀若谷、服务客户
     微软公司对技术相当重视,对合作伙伴和客户也同样重视。作为软件平台公司,合作伙伴和客户都是公司的命脉。微软公司在价值观中强调,所有员工都要信守对客户和合作伙伴的承诺,而且在产品研发过程中,不仅要考虑到产品的技术特性,还更要关注客户和合作伙伴最需要的功能。

     微软的大企业产品部鼓励每一个员工在加入公司的前几个星期到技术支持中心工作,帮助客户解决问题。无论一位员工的资历有多深,公司都希望他经过最基层技术支持工作的锻炼,能理解客户的困难。在大企业产品部的近一万名员工如果以前没有做过技术支持工作,在公司就没有晋升过某一级别的机会。

     除了要求员工悉心聆听客户意见之外,微软的软件也会自动收集客户的反馈意见。多年前,当Office开发者无法决定该把哪些功能放进常用工具栏时,Office的程序员制作了一套特别的Office软件。这套Office在用户允许的情况下,记录用户最常用的功能,传送到微软。最后,借助这些统计数据,开发者就可以决定什么样的用户界面才会对大多数用户有利。今天,微软把这个技术做进了所有的产品。任何微软的软件碰到问题(如宕机)时会搜集数据,并在用户的允许下经过网络把这些数据传到总部的服务器,以帮助开发人员诊断和测试软件。有了这样的技术,Windows XP推出一个月后,微软就把用户碰到的一半问题都解决了,然后再通过网络自动帮助合所有法用户升级软件。此类工作集中体现了公司的创新精神以及借助软件技术解决问题的目标,当然也体现了公司悉心聆听客户意见的决心。

     寄语中国软件业    

     本文谈到的内容,大都是我个人对微软成功经验的理解以及对软件企业管理者的建议。微软公司是一家成功的企业,其成功的背后隐藏着许许多多有价值的东西。虽然微软公司的企业文化和管理方式不一定适合其他企业,但至少是一个可供参考的优秀范例。下面是从本文中提炼出来的,我个人对中国高技术企业的建议:

•  管理方面

o  积极为公司长远目标投资,悉心地学习研究、开发的机制。理解把握技术的重要性,而不是只注重眼前利益,重复低级劳动。同时也要认识到,市场和用户的需求决定技术和产品的开发, 而不是反之。
o  不做能力以外的工作,不为了“面子”做没有用的研究。切实研究和找到在产业价值链的最有利的位置,以增强自身长远商业实力和股东利益为根本出发点。
o  作专注的公司,不要急于发展而分散了管理者的注意力。唯有足够大的规模才能达到较高的效率, 但规模并不等于无协同性业务的简单合并。中国的软件业公司太多 (近万家),需要整合。中国的软件公司的总裁需要放弃“宁为鸡首”的想法,积极合并。
o  用SMART的目标来衡量每个人负责的工作;把这些目标量化并公开出来。定下决策的框架和流程,每个人都要理解自己在一个决策过程中扮演的角色。
o  要求产品的开发人员直接接触客户,才能真正理解客户的困难和痛苦。用最新的技术进一步地理解客户的需求和满意度。

•  最高领导层方面

o  理解领军人物的重要性。中国需要更多虚心的、勇于改变的、对公司充满热情的、彼此信任的、相互支持的领军人物。
o  有“希望雇佣到比自己强的人才”的胸怀,有“最优秀的人属于公司,支持他们离开自己的麾下”的无私作风。
o  提倡以身作则的管理方式,不让领导拥有“特殊”待遇,不让领导游离于公司的法规和措施之外。
o  有足够的自觉。如果公司的管理工作超出了自己的能力范围,要有让贤的胸怀。
o  要认识到中国软件企业在管理上与跨国公司的巨大差距,要大胆引进海外人才和职业经理人,并积极营造使他们充分发挥作用的环境。

•  人才方面

o  真正做到以人为本,以三顾茅庐的精神去挖掘人才,用长远的眼光培养人才。能够理解“一流的人雇佣一流的人,二流的人雇佣三流的人”的精髓。
o  引入人才管理、评估、培养的制度。追踪、提拔最优秀的人才。积极提高人才对企业的忠诚度。
o  引入职业管理人才机制,在公司战略,营销等领域使用受过正规企业管理培训的专业人才。
o  真正重视技术人才。用“双轨道”机制让技术人才受到重视和提升。
o  提供良好的环境、支持和培训,让优秀的人才没有后顾之忧。
o  实施真正意义上的员工优胜劣汰机制。
o  建立人才激励机制。利用股票期权等机制将员工与公司的长期利益联系在一起。

•  文化和价值观方面

o  发展良好的文化与价值观,并将其灌输到企业的每一部分,要求员工用企业文化和价值观来引导各项工作。
o  以令人振奋的前景目标和巨大挑战激发员工的热情和斗志。让每一个员工因为自己的产品为人类生活带来的发展和改进而激动不已。
o  杜绝官僚作风,创立灵活、平等的文化。让公司的信息自由流通,让每一个员工都有主人翁责任感。
o  公司、领导和员工都自觉追寻卓越的文化;有接受批评的胸怀、承认错误的勇气和扭转劣势的魄力。
o  从上到下树立诚信至上的观念,对上市公司财务报表做到诚实准确。

     我希望国内的软件企业可以从微软公司的成功经验中汲取营养,并创造出真正属于自己的优秀企业文化和管理模式,实现最大的商业价值。

今天,美国大学的实力雄踞世界之首。美国的高等教育不仅是国家向公民提供的一项福利,也是创造社会财富的优良动力。美国卡内基小组的研究表明,美国的经济实力有50%是从它的教育制度获得的。拥有了世界一流的高等教育,美国才能拥有大量的自主知识产权、影响深远的杰出学者和强大的知识经济,才能成为科技强国。

然而,美国高教并不完美。美国在过去一百年中有许多措施、政策、制度、思路值得效法,但近20年来也呈现出流弊日滋的景况。

本文的目的在于分析大学对美国发展的重要贡献,探讨美国大学成功的根本要素,以及近二十年来显现出的弊端。《老子》说:知人者智,自知者明。但愿本文对美国大学体制成败得失的分析能对寻求中国教育制度进步的人们提供一种参照。

 

美国大学成功的五大理由

美国作为世界公认的科技强国,拥有世界50%以上的学术论文、诺贝尔奖得主和专利。美国之所以强大,很重要的原因就是它拥有为数众多的世界一流学府,它们吸引着全世界最优秀的学生负笈美国,一俟学业完成,这些学生很多都留在美国,成为美国支撑其科技强国地位的砥柱。

全世界最好的大学有85%是美国的大学(据上海交大所做世界大学排名,前20名中有17所美国大学)。美国用世界上最优秀的大学吸引世界各地的最有潜质的学生到美国学习,再用它强大的企业将这些人才中的大多数留在美国本土。在微软、IBM、苹果等美国高科技企业中充满了来自中国、日本、韩国、印度、加拿大、法国、英国等国家的拔尖人才。这些异域精英们为美国的科技和产业发展提供了坚实的人才基础。

美国大学的成功有五大理由:(1)英明的政策与官员;(2)灵活自由的教学方式;(3)严格的教师录取、晋升、管理制度;(4)在进步中求稳定的思维;(5)私立大学奇迹般的崛起。

(1) 英明的政策与官员

1862年,美国正着手开发西部,一位有远见的参议员Justin Morrill为了提供落后地区的农工人员受教育的机会,推动实施了《赠地法案》,由政府提供免费土地用以创办新的“赠地大学”。这个法案使每个州分别获得三万英亩土地,《法案》还允许大学将这些土地变卖,用卖地之资作为学校经费。

随着美国的社会财富日益雄厚,国家对大学的经费投入也逐步增加。见到德国的研究型大学获得成功,Morrill和其他参议员又推动实施了新的法案,追加了研究经费和新学科教学的经费,以促成研究和教学并重的“研究型大学”。

尽管有了这些英明的政策和充裕的经费,20世纪初美国的科研和大学仍然落后于欧洲。这时的美国,需要的是一个契机。历史没有让美国人等得太久。二战期间,在美国国家防务研究委员会主任Vannevar Bush的领导下,有六千名科学家机密地进行了大量的科研工作(包括影响深远的对原子弹、雷达、解密算法、导弹和青霉素的研究)。二战结束, Vannevar Bush调任国家科学研究与开发办公室主任。他提交给罗斯福总统一份名为《科学——无尽的战线》(“Science, the Endless Frontier”) 的报告,阐述他设计的一整套国家扶持科技,利用科技创造财富的机制,其主要内容如下:

大幅度提高科研经费。科学研究是国家强盛、人类进步所必需的,政府有责任支持、资助这个领域。从1940到1990年,美国的研究经费涨了4000倍。2000年,美国联邦政府在科学研究方面的支出超过380亿美元。
 

把国家科研下放给大学。 Vannevar Bush的主要方案之一就是“合同制联邦主义”(Federalism by Contract),其实质就是联邦政府自己不设立研究机构,而是通过签订研究合同的方式,把科研任务交付给大学或私营公司。他与41所大学/研究机构、22家公司签订了二百多个科研合同。美国除了少数的国防机密项目,绝大多数的科研经费都经过美国国家科学基金会、国家卫生基金会、国防部高科技组织、海军研究办公室等提供项目,通过竞争方式下放给研究型大学和其它实验室来操作。
 

引导国防科研产业化。二战时发明的很多技术都有巨大的商业价值,Vannevar Bush 力主由大学(象麻省理工学院的 Lincoln Labs,加州理工学院的 Jet Propulsion Lab)来做这些技术的下一步科研工作,然后经过国防承包商(象波音、Lockeed、BBN)将这些技术产业化。这一系列措施催生了世界一流的大学和公司,巩固了美国作为世界第一科技大国的地位。
 

美国当局从谏如流,Bush报告中的三点从此为美国现代科研政策定下基调。

《科学——无尽的战线》所力倡的开放式科研和苏联的集中式科研理念上截然不同。国防科技方面,苏联有星有弹,并不比美国逊色。但是苏联的集中式科研与社会隔离,武器做得越先进,社会越穷。最后整个国家陷入经济恐慌,失去科技强国的地位势所难免。而美国的开放式科研,由大学负责创新,由企业负责产业化,每一项发明都能充分发挥它的潜力,同时也为大学和产业带来了无比巨大的推动力。

Bush这些明智的政策使得大学在经费上富可敌国(实行“合同制联邦主义”的初期,麻省理工学院就得到一亿美元的经费),大学里面群英荟萃。从此,不但美国大学后来居上超过欧洲,美国的高科技(航天航空、医学、计算机、操作系统、网络……)也迅速产业化,创造了无比巨大的财富。另一方面,大学教授和毕业生创业成功后,将他们的知识和财富重新输入大学,形成生生不息的良性循环。

在此,我们不能忘记这个伟大进步的功臣:英明的官员。Vannevar Bush就是其中最卓越的典范。他本人不仅是政府官员,也是有独具慧眼的战略家和卓越的科学家。他在1931年研制成功的“微分分析仪”(Differential Analyzer),是电子计算机的鼻祖。他在1945年写的 “As We May Think”一文,预测了未来计算机、数据库、数位相机、语音识别、Internet等功能,有人因此称他为电脑之父。Vannevar Bush曾任麻省理工学院的副校长,曾创有名的Raytheon公司,也是美国专利系统的创始人之一。如果Vannevar Bush没有步入仕途,他很可能获得诺贝尔奖。然而,作为运筹帷幄的政府官员,他对美国社会的贡献远远超过大多数诺贝尔奖得主。他的例子昭示我们,教育、科研和经济的进步不但需要大量经费投入和开明的政策,也需要具备大师智慧的官员。 

(2)  灵活自由的教学方式

美国的教学方式非常灵活,风格上跟欧洲大不相同。教师和学生在直截了当的氛围中交流思想、学习知识。无论是在小学、中学还是大学,美国教师一般不会对学生进行大量的知识灌输,而是采用实验、案例、讨论、互动交流等丰富生动的方式提高学生的学习积极性。

在美国的大学,教师鼓励学生追逐兴趣而不是追逐“热门”,开明的校规也允许学生根据自己的兴趣转系。我刚进大学时想从事法律或政治工作。一年多以后我才发现自己对法律没有兴趣,学习成绩也只属中等,但我爱上了计算机。我每天疯狂地编程,很快就引起了老师、同学的重视。终于,大二的一天,我决定放弃此前一年多在全美前三名的哥伦比亚大学法律系已经修得的学分,转入哥伦比亚大学藉藉无名的计算机系。若不是开明的校规允许我转系,今天我就不会拥有计算机领域的成就,很可能只是在美国某个小镇上做一个既不成功又不快乐的律师。

在美国的大学,教师还非常注重培养学生独立思考的能力,鼓励学生大胆提出自己的设想和建议。我读书时,曾提出与导师的思路截然不同的技术方案。当时我的导师说:“我不同意你,但是我支持你。”他的鼓励最终促使我沿着自己的道路获得了成功。这种因材施教、鼓励创新的教育理念再好不过地体现了美国教育思想的先进性。

(3)  严格的教师录取、晋升、管理制度

美国的高等院校大多拥有一流的师资,可谓大师云集。在美国社会,大学教授是知识分子梦寐以求的职业,有着很高的社会地位和优渥的待遇。优渥的待遇保证了师资质量,优良的师资带来学生对老师的尊崇,学生的尊崇又使老师社会地位提升,结果是待遇又继续提高,从而形成大学师资的良性循环。

在麻省理工学院或斯坦福大学这样的一流学府,一个教授职位常常有上千人同时申请。当一名青年教师,击败了上千名竞争对手,进入斯坦福大学作助理教授后,他只得到一纸为期7年的聘书。7年后他有50%的机会得到“终身职”,得以终身留在学校。但是他也有50%的可能得不到“终身职”,必须放弃成为教授的目标,甚至失业。这样苛刻的条件下一个职位仍有上千人申请,我们可以想象教授在美国是多么令人向往的工作。

“终身职”制度有两个目的。第一,确保教授合格。获得“终身职”教授职位极为困难。申请者需要做多项独立科研、在高水平的期刊发表文章、成功地指导博士生,再经过严格的师资评审制度,由同行教授进行客观考评,仔细衡量对科研的实际贡献,加上学生的评语等,然后才能证明其“终身职副教授”的资格。如此高的门槛,保证了教授的质量,也保证了教授的社会地位。第二、保障思想自由。一旦获得“终身职”,学校不能因为思想偏激或攻击学校、政府而解雇教授,等于提供“终身”保障。

此外,美国高等院校在管理上强调专注于教育和基础研究,不鼓励大学办企业、不鼓励教授拿过多的横向项目,以免影响教学质量。大学教授本来就有丰厚的薪酬,还可以每周抽出一天做待遇不菲的“顾问”工作,更可以选择时机留职停薪到社会上创业。所以美国教授没有后顾之忧,也能够公私分明,把在校时间全力投入到科研和教学。

(4)  在进步中求稳定的思维

19世纪以前,欧洲的大学主要训练的是教士和政治家。在前现代社会,人们心目中世界是稳定的,并且从根本上讲是已知的,如果说还存在未知的部分,那也一定可以从已知的知识出发推导出来,因为秩序是一以贯之并且无所不在的。未来在某种意义上被想当然地认为是历史的重演,人们从未设想过这个稳定的世界秩序会存在被颠覆的危险。在这种历史背景下,教育的目的是传授固定的知识。大学最重要的品质是稳定。

自19世纪以降,世界发生了深刻的变化。工业革命、信息革命、医学革命带给了人们希望,核子武器、恐怖主义、环境危机、能源危机带给了人们恐惧,两次世界大战动摇人类对自身智慧和理性的傲慢……随着伦理、道德、信仰、哲学、科学的深刻变化,人类开始意识到,未来将不再是过去的重演。这种时代趋势给教育带来深刻的影响。从此,教育的指向不再是重复僵硬的知识或真理,而是创新。而大学最重要的品质也不再是守旧的稳定,而是迎着风险追求进步。

就在古老的世界因创新而变得年轻的转折关口,美国的大学把握机会,在“进步”的旗帜下,在胸有韬略的教育家领导下,超过了欧洲以“稳定”为要的大学(德国的大学是一个例外)。美国本是一个多元文化大熔炉,美国的大学为了进步敢于创新也愿意模仿。很好的一个例子是19世纪在德国柏林大学这种研究型大学大获成功的启发之下,美国的大学迅速将德国模式融入美国本土教育,再加上政策的支持,很快青出于蓝,超过德国研究型大学的成就。另一个例子是MIT最近以一亿美元总经费计划将2000门课程(包括课本、演讲稿、笔记、习题、答案等)无偿地在网上公开。这不但代表了MIT拥抱网络技术和远程教育的进取心,更显示了它不惧风险,并对蝉联世界工科领导者地位的无比信心。

在处理进步和稳定的关系问题上,美国大学提供了值得效法的范例。且听加州大学校长Clark Kerr的夫子自道:“进步和稳定都重要,但是我深信进步比稳定更重要,因为惟有进步才能带来真正的、长远的稳定。因此,当两者有冲突时,我们应该放弃稳定而追求进步。”在过去的一百年中,美国奉“在进步中求稳定”的理念为圭臬,终于后来居上地超过欧洲老牌大学,令全世界为之瞩目。这个理念,正是美国大学至关重要的成功秘诀。

(5) 私立大学奇迹般的崛起
 

美国的大学可分五类:

1. 私立大学 – 是在有理想的成功人士捐赠的基础上建成,归私人所有,由董事会管理。这类大学不以盈利为目的,股东不得获取利润分成,所有收益用于学校发展及提高科研教学水平。

2. 公立大学 – 如各州立大学,完全由政府出资,满足公民接受高等教育的基本需要,体现了教育资源利用的公平性、正义性和便利性。

3. 教会大学 – 出于宗教目的,由教会拥有,补充社会基本教育条件并服务宗教目的。

4. 公立社区大学 – 提供低学费的两年制学位教育,瞄准那些无法进一流大学的学生。也有学生为了省钱,先读两年社区大学再转学到公立或私立大学。

5. 私立职业大学 – 以盈利为基本目的,相当于企业或者公司,这类大学一般收费较高、办学水平较低,类似中国现有的许多民办大学。

一个突出的现象是,最优秀的大学中大约有85%都属于上面第一类,即私立大学。这一点从美国新闻和世界报道的排名也可以看出:
 

总体排名 (美国新闻和世界报道)
 
 
 本科
 商学院
 工程
 
1
 哈佛
 哈佛
 麻省理工学院
 
2
 普林斯顿
 斯坦福
 斯坦福
 
3
 耶鲁
 宾州大学
 伯克莱*
 
4
 麻省理工学院
 麻省理工学院
 依利诺斯*
 
5
 加州理工
 西北大学
 乔治理工*
 
6
 杜克
 哥伦比亚
 密歇根*
 
7
 斯坦福
 杜克
 加州理工
 
8
 宾州大学
 伯克莱*
 普杜
 
9
 Dartmouth
 芝加哥
 德州*
 
10
 华盛顿大学
 Dartmouth
 卡内基梅隆
 

 

高科技学科领域领先的学校 
 
 生物工程
 计算机科学
 计算机工程
 
1
 斯坦福
 卡内基梅隆
 麻省理工学院
 
2
 哈佛
 麻省理工学院
 卡内基梅隆
 
3
 麻省理工学院
 斯坦福
 斯坦福
 

(注:加*为公立学校,其余为私立学校。)
 

这些私立大学都是常说的“研究型大学”,它们不但提供优质的教育,而且做一流的研究。尽管公立大学拥有政府的资助,私立大学和公立大学之间的差距却是越拉越远。私立大学不仅仅是成功的学府,还成为产业的核心:硅谷的崛起归功于斯坦福大学,波士顿周围高科技产业的兴旺则依靠麻省理工学院。

为什么美国能打破过去公立大学一方独霸的局面呢?是什么让私立大学成为美国高等教育的核心力量呢?美国的研究型私立大学的成功具备下列四个重要条件:

有理想的慈善家:上面表格中的每一所私立大学都是用爱国的慈善家(如Carnegie, Mellon, Stanford, Rockefeller,Harvard)的捐赠创立。其中Rockefeller除了捐赠多所大学,还提供了研究资金,在政府尚未看到微生物学的潜力时,他一掷千金,支持加州理工学院等学校创设这个重要的学科,令美国抢得学科发展的先机。
 

雄厚的私人捐赠基金(endowment):经过多年苦心经营,一流的私立大学培养了大批成功的杰出校友。这些校友又对学校慷慨解囊,帮助学校累积了富可敌国的财富,这就是所谓的基金(endowment)。以哈佛大学为例,它的基金会高达一百多亿美元,而且每年都有盈利。用这笔钱,学校给优秀的学生提供全额奖学金、出最高薪挖来最好的教授、无偿地把课程放在网上、建立科学园区…
 

雄才大略的校长和富有特色的大学:这两者相得益彰,密不可分。雄才大略的校长用自主的办学方针和鲜明的办学特色带领学校达到卓越。每个学校都有它的个性,它们不是枯燥的生产线造出来的陈陈相因的货品,也无法用从第一名排到最后一名的线性思维论定坐次。很经典的例子是Daniel Gilman,他作为Johns Hopkins的首任校长,以研究型大学为理想,在短期内创造了奇迹。除此之外,还有雄才大略的校长和计算机系主任把Carnegie Mellon铸造成一个以IT革命为宗旨的学校;加州理工大学的校长和副校长Noyes, Milikan, Hale把这所原来表现平平的Throop Institute改造成小巧精悍的理工大学;麻省理工学院邻近哈佛,所以决意发展工科,最终修成正果;西北大学的骄傲则是它世界第一的商学院;伯克莱树立了蜚声世界的自由开放学风……每一所有特色的学校都吸引有特色的人,他们在适合的学校环境里尽情发挥,形成人尽其材,各施所长的局面。
 

灵活高效的运作:私立大学在成本控制、运作效率、吸引学生及响应社会需求方面,都比公立大学灵活和有效得多。私立大学不受美国政府政策的限制,也不用每年苦等年度经费,因为私立学校的资金来自基金会,得以像私人公司一样灵活地运作。它们能够以更大幅度的高薪来挖研究大师,提供研究启动经费,它们可以创设新的学科,这种灵活运作的方式正是市场经济的独到之处,因此私立大学可以达到高质量的教学水平,培养高素质的学生。而且,更自由的环境也更能吸引人才。一所大学的成败取决于能否吸引杰出人才,而杰出的人才向往灵活和自由的环境。

 

美国大学面临的五大弊端

对于改革中的中国教育,美国是很好的典范。但是,当我们羡慕美国的成功时,也要看清今天美国大学的弊端。

今天的美国大学有下列五大弊端:(1)“终身职”制度造成教授不思进取;(2)学费经费失衡导致“大学行销竞争”和“盈利型大学”泛滥;(3)院系贫富悬殊、校方大权旁落;(4)研究型教授身价暴涨、优秀教师饭碗不保;(5)一流学府垄断格局日趋僵化。

(1)  “终身职”制度造成教授不思进取

“终身职”制度用较高的门槛来遴选教授是很正确的做法,但是“终身职”也对美国教育产生副作用:得到“终身职”之后,一些教授便高枕无忧,不再努力工作。有些教授高踞其位,其实已半退休,要么就在外创业。这是因为,教授在得到“终身职”后就不再有约束,制度上无法促使他们竭尽全力地担当起对学校和学生的义务和责任。如果在企业,无论职位多高,做得不好,依然会被降薪、降级、甚至解雇。相形之下,大学也应参照企业管理的方式,才能确立令人信服的公平竞争。

(2)学费经费失衡导致“大学行销竞争”和“盈利型大学”泛滥

伯克莱大学教授David Kirp的"Shakespeare, Einstein, and the Bottom Line"一书批评了美国的大学由于近年政府经费削减而产生的学费暴涨。为了生存,很多学校采用行销手段推销自己。行销本身不是坏事,在学费、经费问题无可回避的情况下,适当地融入行销手段有其必要性。但是,有些大学采取夸大、不实的行销手段,不惜通过投机甚至作假来提高排名和提升大学品牌。

此外,很多大学忽视基础学科,因为基础学科拿不到经费。很多大学在雇用校长、副校长时忽略学术和管理能力,而主要看他们的行销能力。这一点已经成为美国教育系统的重大隐患。

正当主流大学遭遇经费问题时,一批盈利型大学乘虚而入。这些学校(如Devry University, Phoenix University,Jones International University 等等)以中专水平僭称“大学”名号,竟然门庭若市,很快积累了数十万学生。分析这些学校发迹的门路,不难看出端倪:他们拿不到国际认证,就拿州立或市立认证,照样可以得到政府的补助;它们得不到媒体的好评,就在电视上大做广告;它们吸引不到优秀学生,就降低入学门槛;它们为了提高利润,就以最低的代价,最少量的课,最少的专业教师,通过网络教学……这些盈利型大学利用主流大学的危机大发了一笔横财。Devry大学的控股公司已在纽约股票市场上市,市值为15亿美元,总裁每年收入180万美元。然而,看到大学文凭贬值,教育沦为商人掠夺纳税人尤其是贫苦学生的摇钱树,人们不禁要质问:公理良知何在?教育作价几何?

(3)  院系贫富悬殊、校方大权旁落

为了提高各个院系争取经费的积极性,很多美国大学降低学校“提成”,缩减校方的权力,而把权力下放给院系。这造成了冷门院系经费捉襟见肘,热门院系却财源滚滚的局面。例如,伯克莱大学为了大笔研究经费,开始做不开放的研究。南加州大学推行“资源管理下放”的管理制度,要求各学院自负财务盈亏,导致课程变质,院际公共设施的经营品质下降。Virginia的商学院不满校方“提成”太多,干脆自立山头,设法脱离母校。流风所及,大学的各个院系几成盈利性公司。

此外,院系独立还导致校长大权旁落。今天。我们已经很难看到像过去哈佛的Eliot校长、Johns Hopkins的Gilman校长,芝加哥大学的Harper校长那样的集社会理想与胆识气魄于一身的教育家。

 

(4)  研究型教授身价暴涨、优秀教师饭碗不保

另一本题为"The Uses of the University"的书,作者是加州大学校长Clark Kerr,分析了美国大学荒废教学的深刻危机。随着大学经费日甚一日地仰仗科研经费,研究与教学并重的大学已变成重研轻教。目前,一个大学或者院系的品牌取决于它有没有一流的研究型教授,这使得大学以天价去挖研究型的明星教授。纽约大学在5年内挖来的法学和哲学明星教授使它有两个系从原先不列名跃升到前三名。然而,大牌明星教授最大的问题是都不愿意教学。于是,纽约大学又只好聘来大批“教匠”应付教学之需。大牌明星教授年薪可以高到一年20万美元,而“教匠”教一门课只有三千元,而且不算学校正式员工。如果“教匠”所授课程明年冷门了,他将彻底失业。

很多美国名校的学生都认为教授只关心研究,不关心学生的学习。最终吃亏的还是学生,尤其是本科生。

(5) 一流学府垄断格局日趋僵化

上述四点弊端,倘若出现在50年前或100年前的美国,很可能会被某个慈善家或教育家通过开创或改造一所大学而得到改进。但在今天,这样的变革契机已经不复存在,因为 “一流私立大学”的市场已被垄断。

这种垄断除了靠私立大学的品牌、师资、研究,还有一个重要的镇山之宝,那就是它们的基金(endowment)。哈佛、斯坦福等大学都有超过百亿美元的基金。仅仅这个基金的利息就已经超过很多学校多年的经费。只用利息,学校可以就可以雇最好的教师、补助不够的经费、或者进行扩张。实际上,它们甚至根本不需要动这笔“老本”,这些私立大学凭他们的品牌和实力就能拿到天文数字的科研经费,基金只会年复一年像雪球般越滚越大。

二流学校根本不可能与这些垄断市场的一流学府竞争,也不再会有慈善家敢于拿钱来和他们竞争(谁愿意投资几百亿,并且惨淡经营几十年后也只能达到“准一流”的档次?何况名校出身的慈善家对自己的母校都很忠诚)。因此,Johns Hopkins、芝加哥、斯坦福挑战哈佛的历史将不会重演。由理想的教育家和慈善家共襄盛举缔造历史的时代已经远去。现在,一流大学的作风和政策早已固定,在没有挑战的情况下,很难出现任何改革。

 

寄语中国

中国正在成为世界经济强国,美国大学的利弊得失对中国来说具有重大借鉴意义。就中国的发展目标而论,中国必须拥有自己的世界一流的学府——无论这个目标有多困难,这都是一个必须完成的任务。

面对这个任重道远的目标,有人夸下海口,声称2020年应可达到;也有人冷言相讥,斥为比超英赶美还不现实。我个人认为这是一个极其困难,但是绝对可以达到的伟大而实用的目标。作为一个科学家和工程师,我深信任何伟大而实用的目标都不该靠闭门造车,而应在实际问题的考验之下,在吸取他人经验教训基础之上寻求发展。

目前,中国的大学在师资、体制、管理系统等方面都离世界一流学府有相当大的距离。若想步入一流,从美国的经验和教训看来,我认为中国必须本着“在进步中求稳定”的思维,增加科研经费投入,革新大学管理系统,改变教学方式,并重研究和教学,推进产学研结合,避免过分产业化,打击由教育获暴利的行为,鼓励有特色的大学良性竞争,并且鼓励创办一流私立大学。如果这些措施果真能够见纳,想来月华如水,桂子飘香的金秋时节,我们是可以期待的。

  我们知道防火墙有四种类型:集成防火墙功能的路由器,集成防火墙功能的代理服务器,专用的软件防火墙和专用的软硬件结合的防火墙。Cisco的防火墙解决方案中包含了四种类型中的第一种和第四种,即:集成防火墙功能的路由器和专用的软硬件结合的防火墙。

  一、 集成在路由器中的防火墙技术

  1、 路由器IOS标准设备中的ACL技术G>

  ACL即Access Control Lis t(访问控制列表),简称Access List(访问列表),它是后续所述的IOS Firewall Feature Set的基础,也是Cisco全线路由器统一界面的操作系统IOS(Internet Operation System,网间操作系统)标准配置的一部分。这就是说在购买了路由器后,ACL功能已经具备,不需要额外花钱去买。

  2、 IOS Firewall Feature Set(IOS防火墙软件包)

  IOS Firewall Feature Set是在ACL的基础上对安全控制的进一步提升,由名称可知,它是一套专门针对防火墙功能的附加软件包,可通过IOS升级获得,并且可以加载到多个Cisco路由器平台上。

  目前防火墙软件包适用的路由器平台包括Cisco 1600、1700、2500、2600和3600,均属中、低端系列。对很多倾向与使用"all-in-one solution"(一体化解决方案),力求简单化管理的中小企业用户来说,它能很大程度上满足需求。之所以不在高端设备上实施集成防火墙功能,这是为了避免影响大型网络的主干路由器的核心工作–数据转发。在这样的网络中,应当使用专用的防火墙设备。

  Cisco IOS防火墙特征:

  基于上下文的访问控制(CBAC)为先进应用程序提供基于应用程序的安全筛选并支持最新协议

  Java能防止下载动机不纯的小应用程序

  在现有功能基础上又添加了拒绝服务探测和预防功能,从而增加了保护

  在探测到可疑行为后可向中央管理控制台实时发送警报和系统记录错误信息

  TCP/UDP事务处理记录按源/目的地址和端口对跟踪用户访问

  配置和管理特性与现有管理应用程序密切配合

  二、 专用防火墙–PIX

  PIX(Private Internet eXchange)属于四类防火墙中的第四种–软硬件结合的防火墙,它的设计是为了满足高级别的安全需求,以较好的性能价格比提供严密的、强有力的安全防范。除了具备第四类防火墙的共同特性,并囊括了IOS Firewall Feature Set的应有功能。

  PIX成为Cisco在网络安全领域的旗舰产品已有一段历史了,它的软硬件结构也经历了较大的发展。现在的PIX有515和520两种型号(520系列容量大于515系列),从原来的仅支持两个10M以太网接口,到10/100M以太网、令牌环网和FDDI的多介质、多端口(最多4个)应用;其专用操作系统从v5.0开始提供对 IPSec这一标准隧道技术的支持,使PIX能与更多的其它设备一起共同构筑起基于标准VPN连接。

  Cisco的PIX Firewall能同时支持16,000多路TCP对话,并支持数万用户而不影响用户性能,在额定载荷下,PIX Firewall的运行速度为45Mbps,支持T3速度,这种速度比基于UNIX的防火墙快十倍。

  主要特性:

  保护方案基于适应性安全算法(ASA),能提供任何其它防火墙都不能提供的最高安全保护

  将获专利的"切入代理"特性能提供传统代理服务器无法匹敌的高性能

  安装简单,维护方便,因而降低了购置成本

  支持64路同时连接,企业发展后可扩充到16000路

  透明支持所有通用TCP/IP Internet服务,如万维网(WWW)文件传输协议(FTP)、Telnet、Archie、Gopher和rlogin

  支持多媒体数据类型,包括Progressive网络公司的Real Audio,Xing技术公司的Steamworks,White Pines公司腃USeeMe,Vocal Te公司的Internet Phone,VDOnet公司的VDOLive,Microsoft公司的NetShow和Uxtreme公司的Web Theater 2

  支持H323兼容的视频会议应用,包括Intel的Internet Video Phone和Microsoft的NetMeeting

  无需因安装而停止运行

  无需升级主机或路由器

  完全可以从未注册的内部主机访问外部Internet

  能与基于Cisco IOS的路由器互操作

  三、 两种防火墙技术的比较

  IOS FIREWALL FEATURE SET PIX FIREWALL

  网络规模 中小型网络,小于250节点的应用。 大型网络,可支持多于500用户的应用

  工作平台 路由器IOS操作系统 专用PIX工作平台

  性能 最高支持T1/E1(2M)线路 可支持多条T3/E3(45M)线路

  工作原理 基于数据包过滤,核心控制为CBAC 基于数据包过滤,核心控制为ASA

  配置方式 命令行或图形方式(通过ConfigMaker) 命令行方式或图形方式(通过Firewall Manager)

  应用的过滤 支持Java小程序过滤 支持Java小程序过滤

  身份认证 通过IOS命令,支持TACACS+、RADIUS服务器认证。 支持TACACS+、RADIUS集中认证

  虚拟专网(VPN) 通过IOS软件升级可支持IPSec、L2F和GRE隧道技术,支持40或56位DES加密。 支持Private Link或IPSec隧道和加密技术

  网络地址翻译(NAT) 集成IOS Plus实现 支持

  冗余特性 通过路由器的冗余协议HSRP实现 支持热冗余

  自身安全 支持Denial-of-Service 支持Denial-of-Service

  代理服务 无,通过路由器的路由功能实现应用 切入的代理服务功能

  管理 通过路由器的管理工具,如Cisco Works 通过Firewall Manager实现管理

  审计功能 一定的跟踪和报警功能 状态化数据过滤,可通过Firewall Manager实现较好的额监控、报告功能

  四、 Centri防火墙

  主要特性:

  核心代理体系结构

  针对Windows NT定制TCP/IP栈

  图形用户结构可制订安全政策

  可将安全政策拖放到网络、网络组、用户和用户组

  ActiveX、Java小应用程序、Java和Vb模块

  通用资源定位器(URL)模块

  端口地址转换

  网络地址转换

  透明支持所有通用TCP/IP应用程序,包括WWW、文件传输协议(FTP)Telnet和邮件

  为Web、Telnet和FTP提供代理安全服务

  根据IP地址、IP子网和IP子网组进行认证

  使用sl口令和可重复使用口令Telnet、Web和ftp提供联机用户认证

  使用Windows NT对所有网络服务进行带外认证

  防止拒绝服务型攻击,包括SYN Flood、IP地址哄骗和Ping-of-Death

  五、Cisco PIX防火墙的安装流程

  1. 将PIX安放至机架,经检测电源系统后接上电源,并加电主机。

  2. 将CONSOLE口连接到PC的串口上,运行HyperTerminal程序从CONSOLE口进入PIX系统;此时系统提示pixfirewall>。

  3. 输入命令:enable,进入特权模式,此时系统提示为pixfirewall#。

  4. 输入命令: configure terminal,对系统进行初始化设置。

  5. 配置以太口参数:

  interface ethernet0 auto (auto选项表明系统自适应网卡类型 )interface ethernet1 auto

  6. 配置内外网卡的IP地址:

  ip address inside ip_address netmask

  ip address outside ip_address netmask

  7. 指定外部地址范围:

  global 1 ip_address-ip_address

  8. 指定要进行要转换的内部地址:

  nat 1 ip_address netmask

  9. 设置指向内部网和外部网的缺省路由

  route inside 0 0 inside_default_router_ip_address

  route outside 0 0 outside_default_router_ip_address

  10. 配置静态IP地址对映:

  static outside ip_address inside ip_address

  11. 设置某些控制选项:

  conduit global_ip port<-port> protocol foreign_ip global_ip 指的是要控制的地址

  port 指的是所作用的端口,其中0代表所有端口

  protocol 指的是连接协议,比如:TCP、UDP等

  foreign_ip 表示可访问global_ip的外部ip,其中表示所有的ip。

  12. 设置telnet选项:

  telnet local_ip

  local_ip 表示被允许通过telnet访问到pix的ip地址(如果不设此项, PIX的配置只能由consle方式进行)。

  13. 将配置保存:

  wr mem

  14. 几个常用的网络测试命令:

  #ping

  #show interface 查看端口状态

  #show static 查看静态地址映射

  六、PIX与路由器的结合配置

  (一)、PIX防火墙

  1、设置PIX防火墙的外部地址:

  ip address outside 131.1.23.2

  2、设置PIX防火墙的内部地址:

  ip address inside 10.10.254.1

  3、设置一个内部计算机与Internet上计算机进行通信时所需的全局地址池:

  global1 131.1.23.10-131.1.23.254

  4、允许网络地址为10.0.0.0的网段地址被PIX翻译成外部地址:

  nat 110.0.0.0

  5、网管工作站固定使用的外部地址为131.1.23.11:

  static 131.1.23.11 10.14.8.50

  6、允许从RTRA发送到到网管工作站的系统日志包通过PIX防火墙:

  conduit 131.1.23.11514 udp 131.1.23.1 255.255.255.255

  7、允许从外部发起的对邮件服务器的连接(131.1.23.10):

  mailhost 131.1.23.10 10.10.254.3

  8、允许网络管理员通过远程登录管理IPX防火墙:

  telnet 10.14.8.50

  9、在位于网管工作站上的日志服务器上记录所有事件日志:

  syslog facility 20.7

  syslog host 10.14.8.50

  (二)、路由器RTRA

  RTRA是外部防护路由器,它必须保护PIX防火墙免受直接攻击,保护FTP/HTTP服务器,同时作为一个警报系统,如果有人攻入此路由器,管理可以立即被通知。

  1、阻止一些对路由器本身的攻击:www.net130.com

  no service tcps mall-servers

  2、强制路由器向系统日志服务器发送在此路由器发生的每一个事件,包括被存取斜砭芫陌吐酚善髋渲玫母谋洌徽飧龆骺梢宰魑韵低彻芾碓钡脑缙谠ぞな居腥嗽谑酝脊セ髀酚善鳎蛘咭丫ト肼酚善鳎谑酝脊セ鞣阑鹎剑?BR>logging trapde bugging

  3、此地址是网管工作站的外部地址,路由器将记录所有事件到此主机上:

  logging 131.1.23.11

  4、保护PIX防火墙和HTTP/FTP服务器以及防卫欺骗攻击(见存取列表):

  enable secret xxxxxxxxxxx

  interface Ethernet 0

  ipaddress 131.1.23.1 255.255.255.0

  interfaceSerial 0

  ip unnumbered ethernet 0

  ip access-group 110 in

  5、禁止任何显示为来源于路由器RTRA和PIX防火墙之间的信息包,这可以防止欺骗攻击:

  access-list 110 deny ip 131.1.23.0 0.0.0.255 anylog

  6、防止对PIX防火墙外部接口的直接攻击并记录到系统日志服务器任何企图连接PIX防火墙外部接口的事件:

  access-list 110 deny ip any host 131.1.23.2 log

  
  7、允许已经建立的TCP会话的信息包通过:

  access-list 110 permit tcp any 131.1.23.0 0.0.0.255 established

  8、允许和FTP/HTTP服务器的FTP连接:

  access-list 110 permit tcp any host 131.1.23.3 eq ftp

  9、允许和FTP/HTTP服务器的FTP数据连接:

  access-list 110 permit tcp any host 131.1.23.2 eq ftp-data

  10、允许和FTP/HTTP服务器的HTTP连接:

  access-list 110 permit tcp any host 131.1.23.2 eq www

  11、禁止和FTP/HTTP服务器的别的连接并记录到系统日志服务器任何企图连接FTP/HTTP的事件:

  access-list 110 deny ip any host 131.1.23.2 log

  12、允许其他预定在PIX防火墙和路由器RTRA之间的流量:

  access-list 110 permit ip any 131.1.23.0 0.0.0.255

  13、限制可以远程登录到此路由器的IP地址:

  line vty 0 4

  login

  password xxxxxxxxxx

  access-class 10 in

  14、只允许网管工作站远程登录到此路由器,当你想从Internet管理此路由器时,应对此存取控制列表进行修改:

  access-list 10 permit ip 131.1.23.11

  (三)、路由器RTRB

  RTRB是内部网防护路由器,它是你的防火墙的最后一道防线,是进入内部网的入口。

  1、记录此路由器上的所有活动到网管工作站上的日志服务器,包括配置的修改:www.net130.com

  logging trap debugging

  logging 10.14.8.50

  2、允许通向网管工作站的系统日志信息:

  interface Ethernet 0

  ip address 10.10.254.2 255.255.255.0

  no ip proxy-arp

  ip access-group 110 in

  access-list 110 permit udp host 10.10.254.0 0.0.0.255

  3、禁止所有别的从PIX防火墙发来的信息包:

  access-list 110 deny ip any host 10.10.254.2 log

  4、允许邮件主机和内部邮件服务器的SMTP邮件连接:

  access-list permit tcp host 10.10.254.31 0.0.0.0 0.255.255.255 eq smtp

  5、禁止别的来源与邮件服务器的流量:

  access-list deny ip host 10.10.254.31 0.0.0.0 0.255.255.255

  6、防止内部网络的信任地址欺骗:

  access-list deny ip any 10.10.254.0 0.0.0.255

  7、允许所有别的来源于PIX防火墙和路由器RTRB之间的流量:

  access-list permit ip 10.10.254.0 0.0.0.255 10.0.0.0 0.255.255.255

  8、限制可以远程登录到此路由器上的IP地址:

  line vty 0 4

  login

  password xxxxxxxxxx

  access-class 10 in

  9、只允许网管工作站远程登录到此路由器,当你想从Internet管理此路由器时,应对此存取控制列表进行修改:

  access-list 10 permit ip 10.14.8.50

  按以上设置配置好PIX防火墙和路由器后,PIX防火墙外部的攻击者将无法在外部连接上找到可以连接的开放端口,也不可能判断出内部任何一台主机的IP地址,即使告诉了内部主机的IP地址,要想直接对它们进行Ping和连接也是不可能的。这样就可以对整个内部网进行有效的保护。